Welcome to the GoFuckYourself.com - Adult Webmaster Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact us.

Post New Thread Reply

Register GFY Rules Calendar Mark Forums Read
Go Back   GoFuckYourself.com - Adult Webmaster Forum > >
New Webmasters ask "How-To" questions here. This is where other fucking Webmasters help.

 
Thread Tools
Old 12-08-2016, 01:41 PM   #1
jollyhumper
Confirmed User
 
jollyhumper's Avatar
 
Industry Role:
Join Date: Mar 2011
Location: Norway
Posts: 382
Perl question

Hi

I'm trying to get a site to work again, but when I try the submit functionality something goes wrong.

This is the part of the Perl script going wrong

Code:
                $pageHTML =~ s/\n/ /g;
		$pageHTML =~ s/\s+$*/ /g;
		$pageHTML =~ s/  / /g;
The error log states the following:
$* is no longer supported at /home/{path to script and script}.pl

Can something else be used instead of $* ??

Thanks
Jolly
__________________
VDBucks - This Asian program converts as hell!. Sign up! | Awesome cam-site |
Email: Jolly [at] pornpitstop (døt) com | Icq: 619 746 889 |
jollyhumper is offline   Share thread on Digg Share thread on Twitter Share thread on Reddit Share thread on Facebook Reply With Quote
Old 12-28-2016, 04:13 AM   #2
MasonSquelch
Registered User
 
MasonSquelch's Avatar
 
Industry Role:
Join Date: Jun 2014
Location: Germany
Posts: 50
It's just a syntax error in line 2, you can't match this way. $ is used for matching the end of a line. If you want to match the "$" sign you may use \$ . In all other cases $ is used for variables. Trying to match $* is no correct syntax. I guess you are trying to substitute several whitespaces (blanks) with a single one; try this:
$pageHTML =~ s/\s+$/ /g;
instead.
__________________
Mental Sinema - Wanktrance Outfitter
MasonSquelch is offline   Share thread on Digg Share thread on Twitter Share thread on Reddit Share thread on Facebook Reply With Quote
Old 12-30-2016, 04:52 PM   #3
jollyhumper
Confirmed User
 
jollyhumper's Avatar
 
Industry Role:
Join Date: Mar 2011
Location: Norway
Posts: 382
Hi

Yea, thanks for the update.
I got some help from a coder and figured it out, it's just what you said.
$ was somehow used differently in earlier versions, when this script was made.

I forgot to update that I found the solution, my script have been working for a while now,
with what is suggested in above post

Thanks
Jolly
__________________
VDBucks - This Asian program converts as hell!. Sign up! | Awesome cam-site |
Email: Jolly [at] pornpitstop (døt) com | Icq: 619 746 889 |
jollyhumper is offline   Share thread on Digg Share thread on Twitter Share thread on Reddit Share thread on Facebook Reply With Quote
Old 12-31-2016, 06:01 PM   #4
MasonSquelch
Registered User
 
MasonSquelch's Avatar
 
Industry Role:
Join Date: Jun 2014
Location: Germany
Posts: 50
No prob, greetings to your coder!
__________________
Mental Sinema - Wanktrance Outfitter
MasonSquelch is offline   Share thread on Digg Share thread on Twitter Share thread on Reddit Share thread on Facebook Reply With Quote
Post New Thread Reply
Go Back   GoFuckYourself.com - Adult Webmaster Forum > >

Bookmarks

Tags
$pagehtml, /g;, wrong, perl, script, supported, question, error, log, /home/path, jolly, script.pl, s/s+$, functionality, submit, site, s/n
Thread Tools




©2000-, AVN Media Network Inc



Powered by vBulletin
Copyright © 2000- Jelsoft Enterprises Limited.